[Home]History of Compiling Halmeter And Halscope

LinuxCNCKnowledgeBase | RecentChanges | PageIndex | Preferences | LinuxCNC.org

Revision 3 . . June 20, 2009 8:14 am by JeffEpler
Revision 2 . . August 23, 2005 9:52 pm by Jmkasunich
  

Difference (from prior major revision) (no other diffs)

Changed: 1,26c1

Compiling EMC2 from the CVS





If the CVS doesn't compile right off the bat, make sure that you have all the necessary -devel packages:

(This is not a complete list yet, but it's a starting point.)

glibc-devel, libstdc++-devel, tcl-devel, tk-devel, gtk+-devel,


> What do I need to add to the BDI-4.20 in order to

> use halmeter and halscope?

You need to have the gtk development package installed.

sudo apt-get update
sudo apt-get install libgtk1.2-dev

Then run emc2's ./configure again. The output from configure includes a line like:

"checking for GTK version... none"
or
"checking for GTK version... 1.2"

If it says none, you don't have the neccessary packages installed, so all GTK related stuff (only halmeter and halscope so far) will be skipped. Once the GTK dev package is installed, you'll get "1.2" or maybe "2.x", and the GTK stuff will compile.





LinuxCNCKnowledgeBase | RecentChanges | PageIndex | Preferences | LinuxCNC.org
Search:
Published under a Creative Commons License